-
Notifications
You must be signed in to change notification settings - Fork 44
/
Insertionsort.cpp
78 lines (63 loc) · 1.62 KB
/
Insertionsort.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
// Code Insertion Sort
// Provided with a random integer array/list(ARR) of size N, you have been required to sort this array using 'Insertion Sort'.
// Note:
// Change in the input array/list itself. You don't need to return or print the elements.
// Input format :
// The first line contains an Integer 't' which denotes the number of test cases or queries to be run. Then the test cases follow.
// First line of each test case or query contains an integer 'N' representing the size of the array/list.
// Second line contains 'N' single space separated integers representing the elements in the array/list.
// Output Format :
// For each test case, print the elements of the array/list in sorted order separated by a single space.
// Output for every test case will be printed in a separate line.
// Constraints :
// 1 <= t <= 10^2
// 0 <= N <= 10^3
// Time Limit: 1 sec
// Sample Input 1:
// 1
// 7
// 2 13 4 1 3 6 28
// Sample Output 1:
// 1 2 3 4 6 13 28
// Solution:
#include <iostream>
using namespace std;
void insertionSort(int *input, int size)
{
int i,j,c;
for(i=1;i<size;i++){
c=input[i];
for(j=i-1;j>=0;j--){
if(c<input[j]){
input[j+1]=input[j];
}
else{
break;
}
}
input[j+1]=c;
}
}
int main()
{
int t;
cin >> t;
while (t--)
{
int size;
cin >> size;
int *input = new int[size];
for (int i = 0; i < size; i++)
{
cin >> input[i];
}
insertionSort(input, size);
for (int i = 0; i < size; i++)
{
cout << input[i] << " ";
}
delete[] input;
cout << endl;
}
return 0;
}